Close

1 de maio de 2017

Dica – Atribuir Variáveis no V3 (VisuAlg 3.0)

O V3 (VisuAlg 3.0) possui duas formas para atribuir valor à uma variável:

usando o dois pontos e com o igual  “:=    (estilo Pascal)”

e também  o menor que com o menos    “<-   (estilo portugol)”

exemplo :

X := 10     ou     X <- 10

Assim estou dizendo ao VisuAlg que a variável de nome X receberá o valor literal 10 (dez)

 

5 Comments on “Dica – Atribuir Variáveis no V3 (VisuAlg 3.0)

Samuel V. B.
13 de novembro de 2017 em 11:10

Gostaria de saber se posso atribuir todos os valores de um vetor em apenas um comando, por exemplo:

vet: vetor [1..12] de rea

vet <- vet(1, 1, 1, 1, 1, 1, 1, 1, 1, 2, 5)

Responder
Renan Borgheti
26 de fevereiro de 2019 em 03:19

Não estou conseguindo fazer a atribuição para variáveis ou constantes do tipo Real com valores decimais. Estou utilizando a versão 3.0.7.0
Mesmo utilizando a sintaxe indicada no manual, ocorre erro ao tentar executar a linha em que faço a atribuição. Ex:

Algoritmo “primeiro algoritmo”

const
// seção de declarações das constantes

var
x: real
inicio
x := 2.5 // ERRO OCORRE AQUI, MESMO UTILIZANDO -<
escreva (x)
fimalgoritmo

Dessa forma, não estou conseguindo passar para os meus alunos, nada que envolva valores reais com decimais.

Agradeço se for respondido

Responder
Professor Antônio
16 de abril de 2020 em 14:20

Estranho, me mande um e-mail para professor.antonio.nicolodi@gmail.com com a imagem (printscreen) da tela e com o seu código também se possível, pois eu testei aqui e está funcionando muito bem

Var
// Seção de Declarações das variáveis
x : real

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc…
x := 2.5
escreval(x)
//…
Fimalgoritmo

Responder
Helton carlos Pereira Luz
29 de outubro de 2020 em 00:55

OLA!
Não estou conseguindo fazer declaração do tipo matriz.

Algoritmo “semnome”

TIPO MAT=VETOR[1..2,1..3] DE INTEIRO; // o erro aparece aqui.

TIPO REG=REGISTRO
NOME:CARACTER
PRECO:REAL
CODIGO:INTEIRO
BAIXA:INTEIRO
FIMREGISTRO;

Var
// Seção de Declarações das variáveis
OP:LOGICO
OPC,X,X1,X2:INTEIRO
NUM:VETOR[1..5] DE REG
MAT:VETOR[1..4,1..6]DE INTEIRO

Inicio

Responder
Arlyson Collins
16 de março de 2021 em 00:26

Excelente trabalho professor só senti falta de poder executar o programa em modo janela como na versão 2.5, na versão do senhor o programa só fica maximizado no monitor principal, não da pra redimensionar a janela nem jogar o aplicativo pra outro monitor caso utilize dois.

Responder

Deixe uma resposta para Samuel V. B. Cancelar resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *